Temporary Downtime of The Payments Dashboard
Incident Report for Fiat Republic
Resolved
The Payment Dashboard is fully operational now.

If you require any further support in relation to this issue, please contact us via Support Portal
Posted Dec 13, 2023 - 08:53 UTC
Identified
We are writing to inform you that The Dashboard is currently experiencing technical difficulties and is not operational at this time.

Please be assured that this matter has been promptly identified and our technical team is actively working on resolving the issue.

The API is fully operational.

We will provide you with updates as they become available. If you have any immediate concerns or need assistance, please do not hesitate to contact us via Support Portal.
Posted Dec 13, 2023 - 08:33 UTC
This incident affected: Payments Dashboard.