Platform Performance Issues (Degraded Performance)

Incident Report for Fiat Republic

Resolved

The root cause was identified on the service provider's side, and a fix has been successfully implemented.
We have verified that our systems are back to being fully operational.

We apologize for any inconvenience this may have caused.
Posted Nov 18, 2025 - 14:55 UTC

Investigating

We are aware of performance issues affecting our platform, related to an outage with an upstream service provider.

We sincerely apologize for the inconvenience and are monitoring the situation to ensure a quick resolution.
Posted Nov 18, 2025 - 12:02 UTC
This incident affected: Payments API, Payments Dashboard, EagleNet, Payments Sandbox, Inbound Payments (SEPA, CHAPS, Faster Payments), and Outbound Payments (SEPA, CHAPS, Faster Payments).