Platform outage
Incident Report for Fiat Republic
Resolved
This incident has been resolved.
Posted Aug 01, 2023 - 17:48 UTC
Investigating
We are currently experiencing issue with one of our providers. Impacted services are listed below.

We will provide the next update in 30 min.
Posted Aug 01, 2023 - 17:11 UTC
This incident affected: Inbound Payments (SEPA, CHAPS, Faster Payments) and Outbound Payments (SEPA, CHAPS, Faster Payments).