SEPA Payments Outage
Incident Report for Fiat Republic
Resolved
The incident has now been resolved.
Posted Jun 21, 2023 - 09:31 UTC
Investigating
We are currently investigating an issue with SEPA outbound and inbound payments. This is due to an outage with our provider.
Posted Jun 21, 2023 - 09:25 UTC
This incident affected: Inbound Payments (SEPA) and Outbound Payments (SEPA).