Intermittent SEPA Credit issues
Incident Report for Fiat Republic
Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 13:17 UTC
Update
Our service provider has effectively resolved the problem that was affecting the processing of outgoing SEPA Credit Transfers.
All SEPA payments that were impacted by the intermittent issue we experienced from 7 p.m. last night, are in a final state now.

If you require any support in relation to this issue, please contact us via the Support Portal.
Posted Oct 05, 2023 - 13:17 UTC
Monitoring
One of our providers is currently experiencing some issues.
As a result SEPA Credit Transfers might be delayed.
Posted Oct 05, 2023 - 09:55 UTC
This incident affected: Inbound Payments (SEPA) and Outbound Payments (SEPA).