Intermittent payments issues
Incident Report for Fiat Republic
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 14:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2024 - 13:29 UTC
Identified
One of our providers is currently experiencing some issues.
As a result, all payments might be delayed.
We're working together on a fast resolution.
Posted Mar 20, 2024 - 10:41 UTC
This incident affected: Payments API, Payments Dashboard, EagleNet, Inbound Payments (SEPA, CHAPS, Faster Payments), and Outbound Payments (SEPA, CHAPS, Faster Payments).