Intermittent Payment Issues

Incident Report for Fiat Republic

Resolved

Our provider has resolved the issue and we can see payments being processed successfully.
Posted Nov 25, 2024 - 19:30 UTC

Investigating

One of our providers is currently experiencing issues with processing incoming payments.

As a result, all EUR and GBP incoming payments might be delayed.
As they're working to resolve this as a priority, we are also closely monitoring the situation.
Posted Nov 25, 2024 - 16:36 UTC
This incident affected: Inbound Payments (SEPA, CHAPS, Faster Payments).