Payment processing - degraded performance

Incident Report for Fiat Republic

Resolved

Payment processing has returned to normal operational status.

The previously observed delays are now resolved.
Posted Jun 04, 2025 - 15:18 UTC

Monitoring

Payment processing speeds are gradually returning to normal, and transactions are now being processed successfully.
We will keep monitoring until full performance is restored.
Posted Jun 04, 2025 - 15:08 UTC

Investigating

We apologies as you may experience Payment processing delays at this time.
We are working closely to resolve this promptly and will keep you updated on the next steps as soon as possible.
Posted Jun 04, 2025 - 14:44 UTC
This incident affected: Inbound Payments (SEPA, CHAPS, Faster Payments) and Outbound Payments (SEPA, CHAPS, Faster Payments).