SEPA Credit Transfer - Payment Delay
Incident Report for Fiat Republic
Resolved
We received notification that our service provider has effectively resolved the problem that was affecting the processing of outgoing SEPA Credit Transfers.

All impacted payments will now undergo processing.
Posted Aug 23, 2023 - 11:03 UTC
Investigating
One of our providers is currently experiencing an issue.
As a result SEPA Outbound Credit Transfers might be delayed.
Posted Aug 23, 2023 - 10:36 UTC
This incident affected: Outbound Payments (SEPA).