Intermittent issues with SMS notifications
Incident Report for Fiat Republic
Resolved
This incident has been resolved.
Posted May 24, 2023 - 16:32 UTC
Investigating
Our SMS provider is currently experiencing an issue with delivery of messages to United Arab Emirates Du Network.
Posted May 24, 2023 - 11:24 UTC
This incident affected: Notifications (SMS).